tirsdag, oktober 27, 2020

Samsung M.2 SSD hjælp!

Daily Rush Debat Hardware Hardware Samsung M.2 SSD hjælp!

  • Forfatter
    Emne
  • #0

    cycron
    Bruger
    830 indlæg
    Offline

    Er ved at bygge nyt rig – men jeg kan ikke få BIOS til at finde M.2 SSD’en (Samsung 960 Pro 1TB) som skal være OS drev. Det bliver heller ikke fundet under Windows 10 installationen. Motherboardet er et Asus X99-E-10G WS.

    – 960’eren har været i et andet motherboard, så jeg ved det fungerer.
    – Har prøvet med en 950 Pro og det blev heller ikke fundet i BIOS.
    – Har prøvet at installere Windows 10 på en SATA SSD, men gjorde ingen forskel.
    – Har prøvet mange forskellige indstillinger i BIOS; ingen forskel.
    – BIOS er nyeste.
    – Har prøvet at loade Samsung NVME drivers under Windows 10 installationen; ingen forskel.

    Nogle tips?
    Jeg kan teste samme motherboard (dog uden 10G ethernet) på mandag. Det må afgøre om det er motherboardet den er galt med.

Viser 13 kommentarer - 1 til 13 (af 13 i alt)
  • Forfatter
    Kommentarer
  • #1

    TormDK
    Bruger
    14.703 indlæg
    Offline

    Hvad står der i manualen om hvilke porte den skal side i?

    Jeg kører Windows 10 Pro på den her maskine med tilsvarende NVMe disk, uden jeg tilføjede ekstra drivere så det skal sådan set virke.

    Mit bundkort er dog en; ASUS Prime Z270-P

    #2

    Phonetic
    Bruger
    23.574 indlæg
    Offline

    #0: Har rettet din overskrift så den er forståelig

    Daily Rush Head Honcho

    #3

    Aben
    Bruger
    1.429 indlæg
    Offline

    Har du prøvet dette:
    https://rog.asus.com/forum/showthread.php?53091-Rampage-V-Extreme-M-2-Setup-And-Windows-Installation-FAQ

    Jeg havde samme problem, men det hjalp for mig at sætte PCI konfigurationen til m2.

    #4

    cycron
    Bruger
    830 indlæg
    Offline

    #1
    Kan du specificere, hvad du mener med hvilke porte den skal sidde i?

    #2
    Tak, det skulle jeg selv tænkt på!

    #3
    Jeg har brugt hele dagen på at kigge efter BIOS indstillinger, som er tilsvarende til det du linker til. Der er ikke rigtig noget man kan indstille mht. M.2 – der findes én enkelt feature, hvor man kan vælge om motherboardet skal auto-vælge M.2 eller U.2 (hvis man har koblet noget via U.2, så er M.2 disablet og omvendt). Udover det kan jeg simpelthen ikke finde noget – fx er der intet mht. PCIe og så M.2.
    Jeg har prøvet at boote Windows 10 USB’en via legacy og UEFI; ingen forskel.

    #5

    cycron
    Bruger
    830 indlæg
    Offline

    Ok – det er så lige gået op for mig, at 6800K CPU’en kun har 28 lanes og motherboardet kræver 40 for at M2/U2 fungerer. Det skal dog lige nævnes, at det på ingen måder står i manualen. Jeg fandt det helt tilfældigvis på Asus’ website omkring specs på motherboardet.
    Det må simpelthen være derfor – jeg kan ikke se, hvad det ellers kan være…

    #6

    Kaalund
    Bruger
    1.548 indlæg
    Offline

    Det kan sgu næsten ikke passe når du kan smide M2 i en NUC.

    Jeg har dog ikke bedre bud var bare for at holde dit håb oppe.

    Origin: LaManchaDK // Steam: KongenDK // UPlay: LaManchaDK // Discord: Jensen

    #7

    MiNo
    Bruger
    2.728 indlæg
    Offline

    PCI lanes er en bitch….

    Har selv en 6700K der ikke har flere lanes og det spiller bare med NVMe, men i er z170 mobo.

    Men så skal du jo bare ha’ en fuldfed CPU

    i7-6700K@4.5 Ghz|Noctua NH-D14|Asus Z170|GTX1080ti|32GB DDR4|Pro 950 512GB NVMe|2x 850 Evo 1TB SSD|CORSAIR AX 850W|R5|Asus PG279Q

    #8

    Timberjim
    Bruger
    3.781 indlæg
    Offline

    Har siddet med et lignende problem før. Og jeg mener bestemt, at løsningen var relateret til noget UEFI/Legacy knas. Der var dog mere end det, der skulle indstilles (måske noget security af en art?).

    #9

    titan_jtl
    Bruger
    267 indlæg
    Offline

    Kender ikke lige dit board, men der er også nogle boards, hvor m.2 og sata, deler lanes så derfor vil kun nogle sata porte virke hvis du bruger m.2. Måske det er noget der skal indstilles i bios?

    #10

    Philo
    Bruger
    1.650 indlæg
    Offline

    Er secure boot slået fra ?

    Make Them Or Take Them ¥ $ € £

    #11

    TormDK
    Bruger
    14.703 indlæg
    Offline

    #10 Virker fint med med Secure Boot slået til.

    #12

    Philo
    Bruger
    1.650 indlæg
    Offline

    #11

    Var også et skud i tågen =)

    Make Them Or Take Them ¥ $ € £

    #13

    Obisoft
    Bruger
    144 indlæg
    Offline

    #0 Taget fra http://www.tomshardware.co.uk/answers/id-3268621/samsung-960-evo-detected-bios.html#r19032612

    1 - Make sure you unplug all SATA and USB drives, the M.2 drive has to be the only drive installed.
    
    2 - Go into the bios, under the boot tab there is an option for CSM, make sure it is disabled.
    
    3 - Click on secure boot option below and make sure it is set to other OS, Not windows UEFI.
    
    4 - Click on key management and clear secure boot keys.
    
    5 - Insert a USB memory stick with a UEFI bootable iso of Windows 10 on it, USB3 is quicker but USB2 works also. A Windows DVD won’t work unless you’ve created your own UEFI Bootable DVD.
    
    6 - Press F10 to save, exit and reboot. 
    
    7 - Windows will now start installing to your NVME drive as it has its own NVME driver built in, I don't think this would work with previous versions.
    
    8 - When the PC reboots hit F2 to go back into the BIOS, you will see under boot priority that windows boot manager now lists your NVME drive.
    
    9 - Click on secure boot again but now set it to WIndows UEFI mode.
    
    10 - Click on key management and install default secure boot keys
    
    11 - Press F10 to save and exit and windows will finish the install.
    
    Once you have Windows up and running, shutdown the PC and reconnect your other SATA drives. Do not put anything on SATA port 1 as this is now reserved for the NVME drive.
    
    I would also recommend installing the Samsung NVME driver at this point to replace the Windows one.
    
    The background here is NVME SSDs do not appear within the BIOS until Windows creates the system partition with the EFI Boot Sector.
    
    Your M.2 SSD contains UEFI driver information within the firmware. By disabling the CSM module Windows will read and utilize the M.2-specific UEFI driver.

    "Only when facing challenge do we face ourselves"

Viser 13 kommentarer - 1 til 13 (af 13 i alt)
  • Du skal være logget ind for at kommentere på dette indlæg.