lørdag, september 26, 2020

Excel DropDown menu

Daily Rush Debat Off-topic Excel DropDown menu

  • Forfatter
    Emne
  • #0

    aruzza
    Bruger
    596 indlæg
    Offline

    Halløj

    Er bange for at mine google/youtube skills er gået tabt. (også på excel)
    Jeg kan intet info finde omkring :
    Jeg vil gerne lave en dropdown menu, denne drop down skal..
    hente data/vise specifik data ved valg.

    Så på Ark1, har jeg en dropdown menu, hvor jeg kan vælge feks. hund, hest, ko, gris.
    Når jeg vælger ko, trækker den data fra Ark2, og viser kun de info jeg har tastet omkring dette valg.

    ps. dropdown menuen er der masser af info om, men intet om hvad man så videre skal gøre, for at valg af værdig giver udslag

    pps. jeg ved jeg er uduelig til excel

Viser 9 kommentarer - 1 til 9 (af 9 i alt)
  • Forfatter
    Kommentarer
  • #1

    Kolben
    Bruger
    18.726 indlæg
    Offline

    Skal det være i Excel? Det lyder som om du er ude i noget du burde løse med et andet værktøj. F.eks. i Access eller lignede.

    P=NP?

    #2

    Steadi
    Bruger
    5.613 indlæg
    Offline

    Mit bud på en løsning (hvis jeg forstår dit behov rigtigt):

    Drop down liste, hvor du vælger dyr.

    Hvis du anvender “SUMIF”, kan du også vælge, at den kun skal anvende tal, der opfylder dine valgte kriterier (“SUMIFS”, hvis du har flere kriterier).

    Det ene kriterie skal være din drop down liste, mens det næste kriterie skal være den data, som du ønsker fremvist.

    Eksempel: du vælger “hund” som det dyr, hvor du godt vil have vist din data om højde, antal eller noget helt tredje.

    Hvis du anvender SUMIF, så behøver du egentlig kun et kriterie, nemlig henvisningen til drop down listen. Hvis du vælger det rigtige interval, så den fx kun søger under “højde”, så behøver du kun et kriterie.

    Gav det nogen mening? Jeg prøver gerne at uddybe, hvis jeg kan. Jeg har reelt ingen officiel forstand på excel, men har forsøgt at lære lidt hen ad vejen.

    Jeg har en engelsk excel-udgave, derfor de engelske navne på formlerne. Har du en dansk udgave, skal du (vist) bruge de danske navne. Mener, at “SUMIF” hedder “SUM.HVIS”.

    Edit:
    Kom lige på et, forhåbentligt, bedre eksempel.

    Hvis du har en liste over storbyer (række A1 til A20) og deres respektive indbyggertal (række B1 til B20), så kan du anvende SUMIF til at sige, at hvis dit valgte kriterie (storbyens navn), findes i A1 til A20, så skal den tælle summen ud for i B1 til B20.

    Selvfølgelig, hvis du har kriteriet København, og det står flere gange på listen, så vil excel opsummere.

    Jeg mener ikke, at du kan bruge “COUNTIF” i din situation, da “countif” blot siger plus 1 hver gang, at det valgte kriterie findes.

    My fellow Americans, I am pleased to tell you I just signed legislation which outlaws Russia forever. The bombing begins in five minutes.

    • Denne kommentar blev ændret for 1 år, 7 måneder siden af  Steadi.
    #3

    Fizk
    Bruger
    210 indlæg
    Offline

    Har du ikke et ark med noget demo data, som du kan lægge op et eller andet sted? – Det ville gøre det lidt nemmere at have lidt mere at gå ud fra end en forklaring.

    https://www.youtube.com/user/esbenboye/videos
    Min YouTube kanel - Med lidt af hvert for friluftsmennesker!

    #4

    Steadi
    Bruger
    5.613 indlæg
    Offline

    #3 – Det pågældende ark har nået en størrelse, så jeg tænker, at det vil forvirre mere end det vil gavne.

    Microsofts office support side har jeg anvendt ret meget, da de har gode eksempler. Den her er for SUM.HVIS / SUMIF.

    https://support.office.com/da-dk/article/sum-hvis-funktionen-169b8c99-c05c-4483-a712-1697a653039b

    My fellow Americans, I am pleased to tell you I just signed legislation which outlaws Russia forever. The bombing begins in five minutes.

    #5

    Fribo
    Bruger
    1.016 indlæg
    Offline

    Har du kigget på lopslag? den søger efter hest i en matrix og gengiver en værdi fra en anden kolonne i samme række

    *Der tages forbehold for eventuelle stavefejl, ulogiske sammenhænge, trykfejl og falske informationer

    #6

    aruzza
    Bruger
    596 indlæg
    Offline

    Link til excel ark, hvor jeg i arket har prøvet at beskrive hvad jeg prøver at opnå
    https://1drv.ms/x/s!AvFMYw3dClU97k_-XQGdTMcrZ1eZ

    (Der er tekst på Ark1 og Ark2)

    ps. jeg har tilladt redigering

    Jeg har kigget på Loopopslag, det er muligt at jeg har misforstået funktionen, men synes ikke det virkede til at den gav det resultat jeg ønskede

    • Denne kommentar blev ændret for 1 år, 7 måneder siden af  aruzza.
    #7

    Fribo
    Bruger
    1.016 indlæg
    Offline

    Lopslag vil kunne gøre det her
    =LOPSLAG(B2;’Ark2′!A2:E6;3)
    her er:
    B2 din dropdown
    Ark2′!A2:E6 området med din data
    3: kolonne 3

    hvis du vælger ford vil den så returne dæk.

    Skal du have data fra alle kolonder ind kan du lave flere opslag
    =LOPSLAG(B2;’Ark2′!A2:E6;3)&LOPSLAG(B2;’Ark2′!A2:E6;4)&LOPSLAG(B2;’Ark2′!A2:E6;5)

    edit
    Det skal lige siges at metden kun vil virke hvis dine bilmærke kun står et sted i din venstre kolonne

    *Der tages forbehold for eventuelle stavefejl, ulogiske sammenhænge, trykfejl og falske informationer

    • Denne kommentar blev ændret for 1 år, 7 måneder siden af  Fribo.
    • Denne kommentar blev ændret for 1 år, 7 måneder siden af  Fribo.
    #8

    aruzza
    Bruger
    596 indlæg
    Offline

    Super, jeg prøver at rode lidt med LOPSLAG.
    Det dælme ikke bare sådan lige at sætte sig ned og lave noget i excel hvis man skal bruge de sjove funktioner

    #9

    Lucky
    Bruger
    3.310 indlæg
    Offline

    Flere muligheder:

    Hvis du absolut vil have en dropdown, så kan det gøres via data validering, vælg liste og derefter markere dine valgmuligheder:
    https://www.techrepublic.com/blog/microsoft-office/how-to-add-a-drop-down-list-to-an-excel-cell/
    Så lige i indlægget at du rent faktisk kan bygge en Dropdown – så kan du have en Hvis/If statement til at udfylde et andet sted.

    Ville selv benytte en pivot eller tabel og derfra lave en slider/udsnit

    Sidst er det muligt bare at tænke i tabel/filtrering tankegang – dropdown menu er bare so last millenium

    Ad nauseam

Viser 9 kommentarer - 1 til 9 (af 9 i alt)
  • Du skal være logget ind for at kommentere på dette indlæg.