fredag, december 13, 2019

Cisco VLAN hjælp

Daily Rush Debat Programmering Cisco VLAN hjælp

  • Forfatter
    Emne
  • #0

    HQX
    Bruger
    1.146 indlæg
    Offline

    Halløjsa!

    Jeg sidder med lidt Cisco problemer og ville høre om man måske kunne få lidt hjælpe fra det fabelagtige DR board.

    Problemet:
    Har et VLAN(3) uden internet adgang, med mindre man indtaster kode/login hvorpå der sidder Unifi devices (8 port PoE switch+APs) som skal have adgang til Cloud Controller på internettet, dette dog uden at VLAN 3 får adgang til nettet.
    Jeg har ikke mulighed for at åbne op til kun Cloud Controller uden om login på VLAN 3.
    Hele pointen er man kan tilslutte ikke konfigureret switches og APs til netværket og så finder de selv hen til Controller. Det fungere fint hvis der ikke er login på netværket, men det login er et MUST.

    Jeg har læst et eller andet sted at man kan sætte et sekundært VLAN(12) på samme port og fange broadcast og så sende det ud på internettet.
    VLAN 12 er pt sat op i firewall til kun at tillade adgang til Cloud Controller.

    Jeg har desværre ikke vildt meget om Cisco da jeg ikke har noget træning i det eller har arbejdet ret meget med det.

    Det jeg har prøvet er:
    switchport access vlan 3
    switchport trunk native vlan 12
    switchport trunk allowed vlan 12
    spanning-tree portfast

    switchport access vlan 3
    switchport trunk allowed vlan 12
    spanning-tree portfast

    Disse to fungere fint i forhold til at give Unifi IPer, men ingen data på VLAN 12

    switchport trunk native vlan 12
    switchport trunk allowed vlan 3
    switchport mode trunk
    spanning-tree portfast

    Ingenting virker …

    Kigget lidt på: https://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus3000/sw/layer2/503_U2_1/b_Cisco_n3k_layer2_config_guide_503_U2_1/b_Cisco_n3k_layer2_config_gd_503_U2_1_chapter_0110.pdf

    Men det er lidt sort for mig.

    Help?

Viser 7 kommentarer - 1 til 7 (af 7 i alt)
  • Forfatter
    Kommentarer
  • #1

    Hansens kammerat
    Bruger
    109 indlæg
    Offline

    Prøv denne(læs mere om det i dit link):

    switchport trunk native vlan 12
    switchport trunk allowed vlan 3
    switchport mode trunk
    vlan dot1q tag native
    spanning-tree portfast

    #2

    HQX
    Bruger
    1.146 indlæg
    Offline

    Switch(config)#vlan dot1q tag native
    ^
    % Invalid input detected at ‘^’ marker.

    Hmph… En Cisco Catalyst 2960 – men den cmd virker altså ikke

    #3

    Hansens kammerat
    Bruger
    109 indlæg
    Offline

    #2 Det viser sig lidt, at du forsøger udføre understøttes ikke at den model?

    https://community.cisco.com/t5/switching/cat2960-native-vlan-tagged-on-trunk/td-p/834221

    Det kan være syntax er andet. Prøv at lave et ? efter hver input altså ‘VLAN ?’ for at se om du får noget konstruktivt.

    #3

    Hansens kammerat
    Bruger
    109 indlæg
    Offline

    Doublepost.

    #5

    Hansens kammerat
    Bruger
    109 indlæg
    Offline

    Jeg er ret sikker på du skal have dot1q tagging på dit native. Ellers skal du finde et andet workaround.

    “To maintain the tagging on the native VLAN and drop untagged traffic, use the vlan dot1q tag native command.”

    https://www.cisco.com/c/m/en_us/techdoc/dc/reference/cli/nxos/commands/l2/vlan-dot1q-tag-native.html

    Ellers vil jeg henvise dig til andre foraer(skriv endelig løsningen):)

    #6

    HQX
    Bruger
    1.146 indlæg
    Offline

    AHA!

    Har fundet fejlen.

    Endelig config
    interface FastEthernet0/20
    switchport trunk native vlan 12
    switchport trunk allowed vlan 3,12
    switchport mode trunk
    spanning-tree portfast

    Men det var slet ikke der problemet var…. Af en eller anden bizar årsag (og jeg har ingen ide om hvorfor) så kunne min Cisco switch ikke se VLAN12, alle andre VLANs omkring den var aktive og synlige, men VLAN 12 var ikke ..

    Sært!

    Tak for hjælpen anyways

    #7

    Hansens kammerat
    Bruger
    109 indlæg
    Offline

    #6 Fandme sejt gået.

    Det giver god mening:
    switchport trunk allowed vlan 3,12

    Alt VLAN som skal komme igennem porten skal blive allowed(det kan du huske til næste gang).

    Native VLAN tilføjer yderligere kompleksitet – derfor var det svært at gennemskue.

Viser 7 kommentarer - 1 til 7 (af 7 i alt)
  • Du skal være logget ind for at kommentere på dette indlæg.